Realtime 2.0 Bulk Storage Outage

Incident Report for Treasure AI

Resolved

We have applied the fix, and are observing that traffic is flowing correctly now.
Posted May 05, 2026 - 10:43 PDT

Update

We are continuing to work on a fix for this issue.
Posted May 05, 2026 - 09:23 PDT

Identified

Incident: Real-time Profile Deletion Workflow Failures
Status: Identified
Impacted Regions: EU01, US01, Tokyo, AP03 (USA)

Update (May 5, 2026 - 11:19 AM CDT)
We have identified the root cause of the failures affecting Real-time (RT) bulk profile deletion, load, and stitch workflows in the affected regions.

Summary of the Issue:
A backend configuration issue resulted in a loss of necessary permissions for the service responsible for processing Real-time bulk profile operations. As a result, impacted workflows are failing with an "Authorization" or "400" error when attempting to invoke internal functions.

Current Status:
Our engineering team has developed a fix and is currently in the process of deploying it to all affected regions. We expect service to be restored shortly after the deployment is completed.


We will provide a further update once the fix has been fully deployed and we have confirmed that workflow processing has returned to normal.
Posted May 05, 2026 - 09:20 PDT
This incident affected: US (Realtime 2.0), Tokyo (Realtime 2.0), and EU (Realtime 2.0).